Payment Issues on My Account Follow
Symptoms
- You receive email notifications and/or in-app notices about failed payments
- You see a red warning icon on your Payment Details section of your My Account page
- You see a message about an outstanding balance
- You see a message about your credit card being expired or invalid
Environment
- www.halocollar.com
- My Account
Resolution
If your payment method is invalid or expired, you will need to update your billing information to keep your Plan and collars active. To do so, follow these steps:
- Log into your account on our website
- Once you are signed in, navigate to "Account Details."
- Select the "Edit" button.
- You will then be prompted to update your payment information in the required fields.
- Once you fill out the required fields, you can select update to pay the balance due
- Once the payment is successful (the card is valid and not expired), the warning message will go away
Plan Cancellation
If you do not address the failed payments for several weeks, after having received 4-5 emails about the failed payments, your Plan will be cancelled. If this occurs, you will also see this warning message on your My Account page:
Restoring a Plan Cancelled for Non-Payment
- Near the Plan Cancellation notice, you will see your current form of payment
- Select the "Edit" button.
- You will then be prompted to update your payment information in the required fields.
- Once you fill out the required fields, you can select update to pay the balance due
- Once the payment is successful (the card is valid and not expired), the warning message will go away
- Once the warning is gone, your can click on the Restore Plan button to re-start your Pack Membership Plan.
Cause
- You have removed the payment information attached to your account
- Your payment method is no longer valid, has insufficient funds or has expired
Additional Notes
If you have any further questions and would like to speak to our live support team, please feel free to reach out using the following article: How to Contact Customer Support and we'll be happy to help!
Comments
0 comments
Please sign in to leave a comment.